I have made my facebook profile open to everyone on facebook but why is it still private?

I have found other facebook profiles open. I know that I have chosen for it to be viewable by everyone on facebook but it is not. Also, is there an option to make it private to some and open to others that are not your friends?

Update:

I have done everything that you both have stated before. I went back to do it all again. I have made it ZERO privacy on every count but still, the only thing that can be viewed is my friends. I want people that are not my friend to be able to read my wall postings and other postings on my home page. But it just won't work.

Update 2:

I have two facebook accounts and in one, I have searched for a guy friend I know for his account. I can see email and contact email. You can click on the picture and see his profile. When I search from my other account, it only shows email by his picture. You cannot access his profile in that one. I am computer savvy but I see no option for this.

2 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    if you go to the facebook home page nd look @ the top of the page(u kno where it says Facebook home profile friends inbox) kepp looking to the right of that nd it says settings. click that then u will c the words privacy and in like purple letters it will say manage click that. then click profile. choose who u want to see ur profile nd make sure u save ur changes.

    where it says blocker user that is where if u have some one u dnt like dnt talk or dnt see then u type in their name or facebook name if u kno that then they wont be able to find u comment on anything of urs or see ur profile.

    hope i helped

    Source(s): me, my friends, and my experience on facebook
  • Anonymous
    1 decade ago

    Enter your Facebook page and go to Settings. Click on E-mail to make sure it has not been turned off and you have the correct address.

    Go to Notifications and make sure your setting are like you want them.

    For privacy and blocking certain people, go to Setting and then Privacy. To may also like to check out Applications.

Still have questions? Get your answers by asking now.