Diana B asked in Computers & InternetSecurity · 1 decade ago

Unable to update Kaspersky IS 7?

I have Kaspersky Internet Security 7 (build 7.0.0.125). I've had it for a few months now and have had no problem with it. A few days ago, the program popped a warning that the "databases were corrupt", and that I should try to upgrade. Every time I tried, however, I got another warning that "not all components were upgraded". I tried rolling back to old .dat, but no matter what I tried, I got the same warning message.

Are there other KIS owners who have seen this? Any solutions?

3 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Try To Uninstall Kaspersky Internet Security 7 Then install again

  • Anonymous
    1 decade ago

    8.0 works for me. But I also wanted to say you have the greatest answers. I really appreciate, and enjoy your responses, even when I may disagree. I hope this helps, and maybe brightens your day.

  • Anonymous
    1 decade ago

    upgrade to 8 will fix your problem

    http://www.kaspersky.com/internet_security_trial

Still have questions? Get your answers by asking now.