HELP! I HAVE SOUND BUT NO PICTURE ON MY XBOX 360.How can I fix it?

I have the HD AV cord and the regular AV cord. They both have sound but they each don't have picture. I tried switching from the HDTV settings to TV setting on the HD cord. I have a standard TV but i don't know if that matters. PLEASE HELP

4 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    I HAD THIS PROBLEM TOO! and no one knew what it was, i tried new cables, and that didnt work so we decided it was the AV input, not the cable. so what we did was wrap the box in 2 towels, turn it on, and leave it running until it overheats (up to 3-4 hours) then try it, if it doesnt work, overheat it again. try it many times until it works, when we did this my box ran anywhere from 2 weeks to 5 months, and then we just did it again.

    eventually though it did get the RROD, then i just sent it in, which was no big deal.

  • 1 decade ago

    Well make sure your cable is on SD not HD. Then remove all memory devices (Hard drive or memory card). Start up the 360 without any memory card or Hard drive and with the SD switch on. It should load. Sometimes the display settings might be off. I hope that helps.

  • 1 decade ago

    Are you hooked correctly yellow=video,red =right spk,white=left spk

    and set to standard on av cord

  • Anonymous
    1 decade ago

    Watch this video:

    http://www.youtube.com/watch?v=Hg92mnpMnWo

    Youtube thumbnail

    FixYa360 has guides to fix the following problems:

    3 red lights

    2 red lights

    1 red light

    E74 and E73

    disc reading errors

    graphic glitches

    freezing

    and more...

Still have questions? Get your answers by asking now.