My Command Prompt seems to be screwed up. Anyone know what to do?

Whenever I type a command into the Command Prompt, it always gives me this error: "[insert command name] is not recognized as an internal command, operable program, or batch file.

I can type in things, such as ipconfig or ping, and they don't work. I've tried to get Microsoft Visual C++ 2005 to work, but it says error spawning cmd.exe, and when it does bring up Command Prompt, the same error shows up. I'm not sure what's wrong or why it's not working.

1 Answer

Relevance
  • 1 decade ago
    Favorite Answer

    Ive had that problem before.. try this man.

    Right click "My Computer" and click "Properties". Click the "Advanced" tab up top followed by the "Environment Variables" button at the bottom. In the 2nd list box, scroll down to the 5th or 6th entry "Path", select it and click "Edit". Add "%SystemRoot%\system32;%SystemRoot%;" (minus the quotes) to the beginning of the line. Okay the changes and try out your commands now.

Still have questions? Get your answers by asking now.