切vlan的routing問題

大家好!我想請問一個vlan問題??

環境如下:

我使用一台cisco ws-c2950和cisco router 2610及3台電腦pc接在switch上我切2個vlan 分別是vlan 2和vlan 3它們的ip網段是如下

vlan 2:192.168.2.0

vlan 3:192.168.3.0

當我照設定方法社定,但不知為何每一個vlan都無法ping到其它vlan電腦但我連要ping要ping trank port的ip也ping不到,所以請問我是那邊觀念錯務呢?下面是switch 和 route的sh run內容:

switch 內容:

Version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname c2950

!

ip subnet-zero

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport mode trunk

switchport trunk allowed vlan 1-1005

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

switchport mode access

switchport access vlan 2

!

interface FastEthernet0/11

switchport mode access

switchport access vlan 3

!

vtp Server

vtp domain poh

!

interface Vlan 1

ip address 192.168.1.1 255.255.255.0

no ip route-cache

!

interface Vlan0002

no ip address

no ip route-cache

!

interface Vlan0003

no ip address

no ip route-cache

!

vlan 2 name VLAN0002

vlan 3 name VLAN0003

!

ip classless

no ip http server

!

!

!

!

line con 0

transport input none

line aux 0

line vty 0 15

!

no scheduler allocate

end

因字數太多放到補充內容繼續~~

Update:

router內容如下

interface Ethernet0

ip address 192.168.1.2 255.255.255.0

no ip directed-broadcast

interface Ethernet0.1

encapsulation dot1q 2

ip address 192.168.2.254 255.255.255.0

Update 2:

interface Ethernet0.2

encapsulation dot1q 3

ip address 192.168.3.254 255.255.255.0

router rip

network 192.168.2.0

network 192.168.3.0

ip classless

no ip http server

line con 0

transport input none

line aux 0

line vty 0 4

!

no scheduler allocate

end

Update 3:

switch 的vtp內容如下

VTP Version 2

Configuration Revision 2

Maximum VLANs supported locally 64

Number of existing VLANs 7

VTP Operating Mode : Server

VTP Domain Name : poh

請各位前輩幫忙一下~到底是哪邊關念設定錯務,謝謝!!

Update 4:

請問大大要多版本才支援呢

但是如果用ISL協定好像也不行通耶

真奇怪不知是SWITCH或ROUTE哪邊錯掉囉

2 Answers

Rating
Still have questions? Get your answers by asking now.