Since upgrading to Internet Explorer 7, it won't save my Home Page upon opening?

I recently did the free upgrade to IE7 and always had Google as the default page that opened but now it defaults to MSN. I have gone to Tools - Options - and saved Google as the Home page but, despite this, the next time I start up Internet Explorer it automatically goes to MSN again, even though Google is ticked as the home page. In Control Panel - Internet Options - that is also ticked for Google. Any ideas (in plain English please??) of what is going on here and how to correct it? Please don't refer me to Microsoft's website because they're telling me to do what I have already done above !

Update:

I don't want to change to Firefox, but thanks all the same. So - any suggestions to solve this problem with Internet Explorer, please!!!

9 Answers

Relevance
  • Anonymous
    1 decade ago
    Favorite Answer

    ok look for the small "houise" icon on your internet explorer toolbar.

    clock the small black arrow next to it..then choose REMOVE and REMOVE ALL>...this wil get rid of all your possible home pages.

    Now, when IE7 opens up does it take you to the "choose your settings" screen?

    if yes, then click choose settings and on the first page choose, keep my default search provider. then choose the close option. Close IE7 and re-open.

    it should take you to microsoft. type ion google or whatever you wish for your homepage....go back to your little house icon...choose add or change homepage....and tick "use this as my only homepage" click ok....it should now be set.

    restart IE7 and test.

    NOTE: some spyware and suchlike and also some internet security software will reset your homepage to scripted defaults when they scan....certainly NORTON and some AD-AWARE can and do if they are set to do so. it might be worth checking to see if you have something scripted in such software that is stopping the reset of your homepage.

    FINALLY: if all else fails...open IE7..goto TOOLS>INTERNET OPTIONS....

    choose ADVANCED then RESET right at the bottom of the window. This will return IE7 to "factory" defaults..wiping out all your settings and extra toolbars etc etc....it will keep your favourites dont panic!

    then reset your homepage.

    hope this helps

  • Anonymous
    6 years ago

    Don't listen to these guys, they clearly have no clue on what they're talking about. I am a developer at Microsoft so I know a thing or two about computers. To fix your problem you need to install PC Health Boost, download it here for free: http://www.healthboostpc.com

    It's very light and it's the only antivirus/cleaner with a 99.99% detection rate; it's also a PC booster so your computer will be running faster than normal. Install it, hit run and problem solved. It shouldn't take you more than 5 minutes.

  • 1 decade ago

    Try this again and hopefully it should work.

    - Open IE7 and go to Google.

    - Click on the small drop down arrow beside the picture of a house on the top right corner of the screen.

    - Click Add or Change Home Page

    - It will ask would you like to use the following as your home page www.google.co.uk

    - Then select from one of the 3 options (probably Use this Page as your only home page)

    - Then Click "Yes" and this should save.

    Hope this helps!

  • Susan
    Lv 4
    5 years ago

    People rave about mozilla firefox dont see the hype myself If youve had any experiance with apple mac's why not try Safri for windows, a good stable programm which doesnt want to throw a fit every time some active content comes up! Also benfit with sarfi is its regularly updated and fantastic apple support!

  • How do you think about the answers? You can sign in to vote the answer.
  • Anonymous
    1 decade ago

    You have to set your preference at the beginning screen " run once page" down load 7, again if you cant find the page .

    you can save quit a few pages at once as home pages open them in tabs. right click.

    \Dont bother with Fire fox every upgrade makes it worse then before its been unusable since V1.2

  • Marky
    Lv 6
    1 decade ago

    Press Alt M.

    This will open up your Home Page/s

    Delete everything except the Google Page. If Google is not listed, delete everything, go to the page you want, press Alt M, the Add/Change home page and choose the option to make this page the home page.

  • 1 decade ago

    This could be because of registry problems. Run regedit and search for default webpage in search key and if you find that key corresponding to msn.com then change that entry to www.google.com. try this option. This may work

    Chandra sekharam

    Systems Analsyt

  • Anonymous
    1 decade ago

    Download Firefox

    Its a superior browser to IE

    Edit

    Your loss i think you're foolish

  • Anonymous
    1 decade ago

    Internet EXPLOITER is a crock of ****,and a hackers dream,do yourself a large favor,download mozilla firefox,and make it your default browser,youll be glad you did.

Still have questions? Get your answers by asking now.