Interenet Explorer keeps telling me it cannot display web page....ANY web page. Please help.?

The computer having problems is my husbands. He can't get on any webpages at all. Not yahoo, mysapce, ebay, NOTHING. The following message displays:

Internet Explorer can't display the webpage. Most likely causes

The website is temporarily unavailable.

The Domain Name Server (DNS) isn't reachable.

The Domain Name Server (DNS) doesn't have a listing for the website's domain.

If this is an HTTPS (secure) address, click Tools, click Internet Options, click Advanced, & check to be sure the SSL and TLS protocols are enabled under the security section.

Etc..... We have DSL & run a router thing so both pcs can use the dsl box. Mine works fine, his won't & we've had it hooked up this way since Feb & are just now having a problem. His myspace im & yahoo im both work. We can send messages back & forth all day but no webpages at all. I hope I've given enough info. PLEASE HELP!

4 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    try this method to check for internet connectivity...

    go to start > run

    then type ping yahoo.com -t

    if you see on the response "reply from ......." then your are connected to the net...but if you see "request time out" you dont have an internet connection so better check your cables, router settings.

    but if: you got a "reply"

    then your I.E is infected with spyware...try scanning your system with antivirus and anti spyware.

    hope this help.

  • 1 decade ago

    check the wiring maybe its loose. or try refreshing the connection by shutting down everything completely,pc,dsl,and all.wait for about 10 minutes before turning it back on.

    if these dont work you might also want to try calling technical support(for dell,hp,etc). im sure they can guide you.

    when it works again remember to download firefox and use that as your web browser instead of internet explorer.

  • 1 decade ago

    Try shutting down your computers, then your router, then your modem. Then reboot them in the reverse order. It's probably your router, but you need to shut everything down and bring it back up so they can start working together again. Ours does that once in a while...

  • 1 decade ago

    1.Check if the network card on the pc is working.

    2.Check the rourter settings.

    3.Try to re-set the rourter.

    Hope this helps..

Still have questions? Get your answers by asking now.