mohaa funny graphics textures ATI Radeon 9600 ?

I am having problems running MOHAA with my new Radeon 9600 series graphics card. It initially worked fine when i installed the card i've now set yp the card and upgraded a couple od other bits on the PC and set up a dual monitor function and now it's stoped working.

The 1st problem was it would't load up at all

"Error loading OIpen GL subsystem"

I dissabled the dual monitor setup and now it loads but all the graphics are messed up in the game. You can still play but the surface textures are all black with flickering yellow and pink grids on them.

Tried a couple of other games and no promlems my spec is shown below:

Processor

Model : Intel(R) Pentium(R) 4 CPU 1700MHz

Speed : 1.70GHz

Performance Rating : PR1865 (estimated)

Type : Standard

L2 On-board Cache : 256kB ECC Synchronous ATC (8-way sectored, 64 byte line size)

Mainboard

Bus(es) : AGP PCI USB FireWire/1394 i2c/SMBus

MP Support : No

MP APIC : No

System BIOS : Award Software, Inc. 2.06

System : 00101440 7970 15305803031326

Mainboard : ASUSTeK Computer INC. WMT-LX

Total Memory : 768MB RDRAM

Chipset 1

Model : ASUSTeK Computer Inc 82850 Host-Hub Interface Bridge Device (A2-step)

Front Side Bus Speed : 4x 100MHz (400MHz data rate)

Total Memory : 1024MB RDRAM

Memory Bus Speed : 2x 400MHz (800MHz data rate)

Video System

Monitor/Panel : A201P1

Monitor/Panel : Default Monitor

Adapter : RADEON 9600 SERIES

Adapter : RADEON 9600 SERIES - Secondary

1 Answer

Relevance
  • 1 decade ago
    Favorite Answer

    First, make sure you're running the latest drivers for your video card. You can find and download the latest ATi drivers here: http://ati.amd.com/support/driver.html

    Also, make sure you're running the latest version of DirectX (version 9.0c) on your computer. You can find the download here: http://tinyurl.com/g7juc

    Source(s): www.ati.com, www.microsoft.com/directx
    • Login to reply the answers
Still have questions? Get your answers by asking now.