when i type search words in my browser other words appear ,how do i delete them?

or turn them off ,everytime i type a word that begins with a i get abi titmus porn,i wish my bro would not use my computer

4 Answers

Relevance
  • tk2
    Lv 4
    1 decade ago
    Favorite Answer
    • Login to reply the answers
  • 1 decade ago

    This has to do with the browser cache and browsing history.

    Firefox-> tools->delete private data

    IE-> Tools->internet options->History->clear history.

    Ur brother has all the rights to surf :)). Just kidding.

    Best of luck

    • Login to reply the answers
  • 1 decade ago

    I don't know how to do it in every browsers, but if you use google search bar, you need only to click < clear the history>

    • Login to reply the answers
  • 1 decade ago

    hit ctl alt delete

    • Login to reply the answers
Still have questions? Get your answers by asking now.