promotion image of download ymail app
Promoted

'95 Geo Prizm engine vibration?

I have a '95 Geo Prizm with about 185,000 miles on it. As long as I've had it the engine (1.8L I believe) has produced a lot of vibration at idle. The whole car shudders when the engine is at idle, but it smooths out when I give it some gas. It also doesn't seem to generate as much power as it should. I know it's a Geo and so it isn't suppose to make much, but it makes less than it should.

I changed the plugs, distributor and rotor recently but this did not affect the vibration or power.

4 Answers

Relevance
  • Anonymous
    1 decade ago
    Favorite Answer

    The problem is in the first sentence: "I have a '95 Geo Prizm with about 185,000 miles on it. "

    • Commenter avatarLogin to reply the answers
  • Evelyn
    Lv 4
    4 years ago

    Relay's are a good start, look at the simple things first known issues. Check all contact points for metal to metal contact. problem with that particular vehicle is rust withen contacts (bulb to socket). Check for good clean grounding of all wiring especially battery connection and grounding wire to frame. I believe you will find this and a new bulb to take care of the dimness.

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    Sounds like you may have a bad motor mount or bad motor mounts. You want to take you car to a shop and have them check you motor mounts and transmission mounts also. these mounts going bad pr breaking will cause vibration.

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    the common problem is the engine valves are worn out. it cause about 700.00

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.