Hard Disk Not Detected in POST / BIOS, Light Constantly On...?

Hi. I have a 20GB Fujitsu HDD that now can't be detected. It originally came with my IBM machine, which used to work fine but I've come back to use it after years and now the HDD cannot be detected in POST. I've altered the jumper settings, the IDE cable and checked that it's plugged in correctly. The HDD LED is constantly on. I've tried another HDD in the IBM machine and it works perfectly.

I have also placed the Fujitsu HDD in another machine with its own HDD, which didn't work. I tried connecting the undetectable disk as a slave, on the same IDE cable as the master disk. This results in both of the HDD's not being detectable at POST. Again, the HDD LED is constantly on. This machine, without the Fujitsu HDD in it, works fine.

I could really do with backing up this disk. As I say though, it is not detected on power up. There are no broken connection pins or any damage on the exterior that I can see. Any advice would be very much appreciated, thank you.

2 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    try flipping the cable or reset the cmos, try to detect it in the bios

  • Anonymous
    1 decade ago

    Sorry for you but it truley sounds like it is dead... depending on how critical the data is it can be recovered but big bucks

Still have questions? Get your answers by asking now.