How do I rectify the audio feedback received in Skype, iChat when using iSight camera and iMac desktop?

I receive an incredible amount of audio feedback of my own voice when using either iChat or Skype. I can hear and see the other party fine. They can hear and see me fine until the audio feedback begins of my own voice. I have tried turning down the speakers, and using a headset. There seems to be some internal microphone link that feeds back the sound back into the system since there is about a 1 second delay. This audio feedback has occurred Mac to Mac using iChat and Mac to Windows using Skype.

3 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Did your headset include its own mic, or was it just output? I am using Skype videocalling with a Logitech fusion webcam, and got some feedback when using the cam's mic and my laptop speakers, but the logitech supplied mic/headphone combo works great. Clear sound, no feedback, and full duplex with no cutout.

    I agree with "twisted" that your system preferences are probably being overridden somewhere.

  • Anonymous
    1 decade ago

    Use a headset, so the microphone does not pick up the sound through the speakers.

    Good luck and Happy Computing!

  • 1 decade ago

    My guess is that Skype is still using the internal microphone of your mac (the little hole to the left of your iSight).

    Go to the sound prefrences (system prefrences > sound), then choose the "input"-tab. In there, you choose the headphone microphone instead of the internal microphone.

    OR, it could be Skype, overriding your prefrences. Go to the Skype-prefrences and on the "Sound"-tab select the headphone-microphone for "Input".

Still have questions? Get your answers by asking now.