Why is my Internet Explorer browser suddenly running so slowly?

All jokes aside about "Your problem is that you are running internet explorer" what's up. I have broadband cable access with a 3 or so year old cable modem through Brighthouse Networks and Roadrunner, I run Norton Antivirus and it checks out. I have Zone Alarm firewall and I use the yahoo anti-spy software, they all check out. I ran an Adaware 6.0 scan and it checks out, yet just in the last week or so, I am continually getting "cannot display page" or "cannot find server" messages and when it does run, it runs slowly. HELP

10 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    You may have spyware, even with your scans. You should try spybot. If this fails, you could also make sure that the browser is updated. Try IE7 candidate one if you have not already downloaded it. I was having similar problems with IE and firefox, but IE7 is working great.

    • Commenter avatarLogin to reply the answers
  • ?
    Lv 4
    4 years ago

    you in all risk have an endemic try Re-booting Your pc If that would not artwork you will would desire to test It With A Anti-virus Scanner This Shoudl help And If no longer, Then Get a perfect Technician To kind It Out

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    I had the same prob turned out it was my internet service providers server, it was broke, they denied it when i called, a week later i called agen they admitted it and they fixed it in like 2 days, my advice, call ur internet service provider

    • Commenter avatarLogin to reply the answers
  • Anonymous
    1 decade ago

    some 3rd party softwares can actually interfere w/ your internet connection (i.e. slow browsing) you may wanna try checking your browsing settings (deleting cache and cookies, resetting websettings, restoring defaults) or try disabling some of the software you have.

    • Commenter avatarLogin to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • 1 decade ago

    clean out your temp files, and cookies run the disc clean up then the defragmenter

    • Commenter avatarLogin to reply the answers
  • try going to internet options, and clear all your personal data, clear your cookies, clear everything that can be cleared. also, try going to every tab, and try to reset all security settings. that might work. if not, it's a hardware problem.

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    You need to reboot, and change some of your settings. Talk to your provider

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    it's prolly your ISP. or you computer. or maybe, it's...wait no you said don't say that. nevermind. by all means it can't possibly be Internet Explorer. nothing wrong with good 'ol IE.

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    run disk defragmentation, clean up your computer delete unnecesary files

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    http://www.superantispyware.com/superant...now that u have what u need....lets clean the pc first

    go to start..run..type in msconfig.....press ok...new window...press start up..select disable all.press apply..press ok

    go to start..run..type in prefetchin new window in top left corner..select edit..select all..press delete.......yes..delete all...

    go to start..all programs..system tools..disc clean up..select c drive..after it has finished analyzing..check all the boxes..press ok..when it has finished cleaning..it will disappear...

    now go to start..control panel...folder options.....view...u will see a option that says "show all hidden files and folders"..check that..press apply..press ok.....

    ok....now we need to go into safe mode....turn off ur computer.....as soon as u turn it back on...u have to press f8 repeatedly until u see a screen that shows u several different options.....u need to enter the option " safe mode" use the arrow keys on keyboard to scrool to it..then press enter...after u afew moments..u will see log on as.....admin or user....select user....after that u will see ur desktop......now open antispyware..( please update this b4 going into safe mode)..click scan my computer....select full or complete system scan.....then press next..it might take ahour or so..after it has finished..remove what ever it finds...now close superantispyware....

    go to start.run..type in...%temp%...press ok..new window..go to edit.select all..press delete..tes..delete all....

    go to start..control panel...folder options.....view...click reset to default..press apply..press ok...

    now restart your computer...u will see a pop up from system configuration...put a check mark in the little box..press ok

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.