Microsoft Keyboard @ and " wrong location?

After upgrading my PC with XP, I found out that my wireless keyboard put the " and @ signs on the wrong keys. On the key with '2' the shift gives @ rather than what is printed on my key, the " sign.

Any idea on how to solve this ?

Thanks, Yoel.

7 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    I think the person telling you to change the regional settings may be on to something. I have never had this happen so I don't know for sure. As for the virus response, I have never had such a laugh as I did at that answer! Thanks to the idiot who posted it, I really needed it. All I can suggest is to try a different keyboard.

    Last note: most, if not all, wireless keyboards do NOT require the included drivers to run as the windows default drivers will do everything. I have a wireless setup (MS Wireless Comfort Edition) and I have never installed the MS drivers and have never had any issues. The ones who do install keyboard drivers usually have issues with their stuff! The same goes for mouse drivers. Leave these resourse hogging applications on the CD and use Windows default and you shall be happier!!!

    • Commenter avatarLogin to reply the answers
  • lolita
    Lv 4
    4 years ago

    I doubt or no longer this is your pc or your keyboard or your Microsoft word 2007. i exploit to do the comparable element you probable are doing. I stored pressing buttons on the keyboard that reason the cursor to bypass, or maybe by threat touching the track pad at the same time as typing, and because I sort so quickly I replace into unaware that I honestly have by threat pressed yet another button. Open Microsoft word 2007 and sort no longer too sluggish nor to no longer quickly. quickly adequate so you might take be attentive to what buttons you're pressing. I wager the cursor won't pass.

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    yes, with Regional and Language Optons, but you must set the keyboard ____NOT___ to English, because here is the problem, you have a keyboard arrangemet that is for another country, maybe Germany but i'm not sure. If you change to correct country, you must also put this setting as Default - on the second tab, on Text Services and input languages, Default Input Language. But, if you don't set correct the language matching your keyboard, you can get wrong keys on other keys....

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    That or you can intall any drivers (on usually a CD-ROM) that came with the wireless keyboard. It's a sure-fire way to know that your comuter is getting the same key you are typing.

    • Commenter avatarLogin to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • 1 decade ago

    Change the rgional and language settings to US from control panel

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    go to controll panel, goto date time languages and regional options and set the area to united kingdom

    • Commenter avatarLogin to reply the answers
  • Anonymous
    1 decade ago

    i think it has something to do with your pc having viruses... it already happened to our pc months ago.. first, try defragmenting your pc... if it still does not work well, try to install a new keyboard and/or bring ur pc to a computer technician =)

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.