My website is showing a list of files instead of my homepage, How do I fix that?

4 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Make sure that your home page is named index.html or index.htm.

    • Commenter avatarLogin to reply the answers
  • Anonymous
    1 decade ago

    Well, as long as you are not using Windows to host the website, it should be very easy.

    Just create a .htaccess file and put in it the DirectoryIndex header and list your main page file under that. And also put in an entry to deny the file list viewing of your website.

    Otherwise, you will have to experiment with the file names until you find the one that your system is set to to use. Here are all the common ones:

    index.htm

    index.html

    index.php

    index.asp

    index.cgi

    index.jsp

    default.htm

    default.html

    default.php

    default.asp

    default.cgi

    default.jsp

    • Commenter avatarLogin to reply the answers
  • Fremen
    Lv 6
    1 decade ago

    The first page of your website isn't and index.html file so without that you are stuck with the listing unless someone is linking directly to a specific front page.

    If you created your website and named your main page something other than index.htm or index.html then you need to change that.

    • Commenter avatarLogin to reply the answers
  • 1 decade ago

    You are accessing the root of your web directory. If you are running IIS than you can fix this by going to the administration and setting the server to point to index.htm or home.htm directly. Or if you are running apache in a linux environment. You can fix this problem by going to conf file under the etc folder and local the setting for home page redirect / path and set it to index.htm anf home.htm. Even simpler just type in the page you want to go to e.g. http://www.mysite.com/mypage.htm Good luck!!

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.