PC Speaker Sound interference driving me nuts! How to fix?

OK my old speakers and sound card were crappy so I assumed it was their fault that I had weird crackly noises. Well I got a new sound card and new speakers but they have crackly noises too! I can hear my mouse wheel turning and I can hear my mouse scrolling over the Windows menus through the speakers. They're more pronounced when I have the volume up but a lot of programs are really quiet so that really exacerbates the problem. What can I do to fix this? I have my CD player volume all the way down in the volume control because I know that makes noises when the CD is spinning but what else can I do?

2 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    From what you said, the most likely cause of your problem can be that you have your “mic” input enabled in playback mode. Even if you don't have a microphone connected, its is the input most likely to introduce unwanted noise, followed by “pc speaker” input, “modem/phone” input and “line in / aux” (in the order of noisiness).

    Make sure you have digital playback enabled on your CD drive (in windows explorer right click the drive then > properties > hardware > (choose cd drive from lis) > properties > properties > make sure "enable digital CD playback" is ticked on. That way the sound from your CD drive is taken to the PC as digital data and has very small chance of unwanted noise getting in as it is the case with the old fashioned “CD in” cable connection to the sound card (you are better off without connecting that cable at all).

    Try going to volume controller (start > accessories > entertainment > volume control (don’t ask me what is so entertaining about the volume controller)) then choose options > properties. If you have more than one sound card or there is a built-in sound device in the mother board, make sure the "mixer device" is set to the one were your speakers are connected. Then choose “play back” and tick on all the controls such as wave, mic, line etc. click ok. Now you can mute all of them and check one by one which one is causing the problem. The only one you really need is the wav out so you can even leave everything else on mute all the time. If the wave channel itself is the one causing the noise, there could be a problem with the sound card or it could be a low quality make. You can also try connecting head phones (even your mp3 player’s ear buds) instead of the speakers to see if the sound is ok on those, in which case the problem is with the speakers.

    Note that you can still use the mic for voice chatting and recording etc even with the mic muted in the play back side of the volume control. Just make sure the “record” side of the control (choose record instead of playback in earlier step) the mic is selected. (by muting the mic in playback you only prevent your own voice being heard from your own speakers but the other person or the recording app will hear it)

    You can also experiment with different combinations for levels of volumes on the PC volume controller and the actual physical volume controller on the speakers (they work independently) and find the best setting to get the loudest possible sound without distortion. (putting both on maximum usually wont give good results).

  • 1 decade ago

    I am not too up on computers but I have a bit of knowledge on some mechanical and electrical things. This is just a hunch, look at the back of your pc tower unit if you have a home pc and I think as my mouse, speakers are possibly connected to the same board, check that first. But you say you are having probs with your cd unit, if you are not scared of opening up your unit then I think you may have a bad earth problem, Last guess, but I don't think I'm right is static on your motherboard and possible others. Hope I have helped you. Ps don't forget to earth yourself to the metal part of your unit to kill the static.

Still have questions? Get your answers by asking now.