I Need help with a new driver?

I Just bought a brand new dvd-R and DVD-RW driver with lightscribe(internal driver)I installed it myself but when I restared my comp it didnt show that it was there. Its almost like it is gone please help me!

10 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Check that you reconnected all the cables (there should be three of them). If you are not seeing any drive at all, then it is not the driver - computers will find CD rom drives automatically. Check the jumper on the back, so that the drive is correctly identified as the master or the slave.

    Make sure the cables are plugged in at the other end too (into the mother board).

    Don't panic! this is not that tough of a problem.

    Cheers!

  • 1 decade ago

    If it doesn't see the drive it is not a driver problem. It's an installation problem. Make sure the jumper on the back of the drive is set correctly. Master for first or only drive. slave for second drive. If the Ide cable has a blue connector into the motherboard (mainboard) set the jumper on cable select. If the drive still doesn't show up hit f2 or delete at boot up to enter your bios.Or is it f1 on some computers? Make sure both channels (primary and secondary) are enabled. Save any changes to bios and exit.

  • 1 decade ago

    There is no driver needed for your DVD-RW. You may have installed software that was bundled with. If this is first time you have installed any drive, there are two things that you might want to check. If your dvd-rw is connected to motherboard along with other drive, you must set one drive as master and the other as slave. (or you can use cable select for both). You also need to set auto detect on IDE drive setting on BIOS.

  • 1 decade ago

    Go to (the links below). Let them scan your PC to see if your drivers are up-to-date. From there it is simple, download the driver and install. For some you will not get an auto installer, you have to download the file to your desktop, and then go to My Computer, right click, Manage, Device Manager, from here look for the device that you are trying to update. If it is not working properly, it will usually have a Red X or Yellow "!". Right click that device, go to Properties, Drivers, and click update drivers. From there you will have the option to browse, so point it to the folder that you downloaded for that device (on your desktop). Hope that helps. (Its easier than it looks!)

    If this does not work, or you do not see your device name in computer management, I would follow the master/slave jumper orientation advice (given by other answers).

    You can only have two devices on one IDE Channel, one has to be set to Master, and one has to be set to Slave, unless they are both set to Cable Select. Either way, you have to let your Motherboard know which takes priority and possibly holds the master boot record for it to access after post.

    Good Luck.

    Source(s): driverguide.com, driveragent.com
  • How do you think about the answers? You can sign in to vote the answer.
  • Anonymous
    1 decade ago

    Try going to the web site of the drive manufacturer and see if they have a driver for the drive that you installed.

    Install the driver and see if your system then recognizes the new device.

    Another possible issue is that the BIOS of you system may not have discovered the device properly. Boot your system to the BIOS (CMOS) configuration screen and verify that the BIOS recognizes the drive as well.

    Good Luck,

    Annorax.

  • 1 decade ago

    Did you try using the Device troubleshooter? Open the control panel (start menu, control panel). Double-click on the 'System' icon. Click on the 'hardware' tab and do to device manager. Go to the DVD/CD rom drives secion and see if your drive it listed there. If so, right-click on it and select properties and see if it is working properly. If it is no tlisted, right click on the 'DVD/CD ROm drives' heading and select scan for hardware changes.

  • 1 decade ago

    I have seen this once. I was told because when I install Nero afterwards, it tried to uninstall Roxio software and corrupted the drive information. You have to go to microsoft.com and search for the solution. I ended up having to correct some thing in the registry.

  • 1 decade ago

    try to regonfigure your in dvd rw into a master setting or the jumper setting and your old cd rom to a slave setting this will work

  • 1 decade ago

    make sure that any other drive that is connected with the same IDE cable is on slave and the DVD burner is on master. (reverse this if the other one is a hard drive.) then restart and it should show up. good luck

  • 1 decade ago

    i'd try to reinstall the driver.

Still have questions? Get your answers by asking now.